Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert sind; Die von diesem Forum gesetzten Cookies düfen nur auf dieser Website verwendet werden und stellen kein Sicherheitsrisiko dar. Cookies auf diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Themabewertung:
  • 0 Bewertung(en) - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
Problem mit Modal
#1
Hallo zusammen,

ich bin noch ziemlich neu in der Web Entwicklungs-Welt und mache gerade meine ersten Erfahrungen mit Bootstrap. Im Moment versuche ich mich an einem Projekt, in dem ich mit einigen Modal Fenstern arbeite, die von einer Hauptseite aus geöffnet werden können. Bei einem dieser Fenster habe ich nun leider ein Problem.

Folgendes soll passieren: ich möchte mit einem Klick auf einen Button ein Modal Fenster öffnen, in dem ich dann eine andere HTML Seite lade (aus einer anderen HTML Datei mit jQuery). Wenn ich das Fenster wieder schließe, soll es ganz normal auf der Hauptseite weitergehen. Von dieser aus könnte ich dann zum Beispiel andere Modal Fenster öffnen.

Code zum öffnen des Modals:

function showModal(id) {
$("#myModalBody").load("/show_mysite?my_id=" + id);
$("#myModal").modal();
}

Folgendes ist das Problem: erstmal funktioniert alles wie gewollt. Per Klick öffnet sich das Fenster und die Seite wird dort drin geladen. Wenn ich das Modal allerdings wieder schließe (über data-dismiss="modal"), kann ich danach keine weiteren Modal Fenster mehr öffnen. Erst nachdem ich die Seite komplett neu geladen habe, geht das wieder.

Die anderen Modal Fenster machen keine Probleme. Darin lade ich aber auch keine  Seiten aus anderen HTML Dateien.

Irgend jemand eine Idee, woran das liegen könnte? Schließt sich das Modal eventuell nicht richtig? Wie könnte ich etwas daran ändern?

Vielen Dank im Voraus
Markus
Zitieren
#2
hast du einen Link?
Zitieren


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
[-]
Willkommen im ersten deutschen Bootstrap-Forum
You have to register before you can post on our site.

Benutzername/E-Mail:


Passwort:





[-]
Letzte Beiträge
Problem mit Modal
Last Post: The-Error
09.07.2019 11:55
» Replies: 1
» Views: 62
Update DSGVO Kontaktformuler Bootstrap 4...
Last Post: The-Error
21.06.2019 11:46
» Replies: 41
» Views: 5151
Amazon peer CSS ändern ?
Last Post: Caro
18.06.2019 21:41
» Replies: 0
» Views: 130

[-]
Private Messages
Please login or register to use this functionality.

[-]
Statistics
» Members: 254
» Latest member: mps
» Forum threads: 219
» Forum posts: 902

Full Statistics

[-]
Tutorials
Get Started
Text/Typography
Gridsystem
Dropdowns
Navigation Bar
Modal
Farben
Jumpotron
Popover
Formulare
Carousel (Slider)
Die Höhe von Elementen mit Klassen h-*
Flip Cards
Bild Overlay-Hover-Effekt
Google Fonts einbinden
Flexbox Bootstrap 4
Responsive Breakpoints

[-]
Wer ist online
There are currently no members online.

>